Hikiを0.5devにバージョンアップする / tdiarygrep がバージョンアップ

投稿日: 2004年01月02月

Hikiを0.5devにバージョンアップする

CVSで取得する必要あり。

http://www.namaraii.com/hiki/?HikiFarm#l1

tdiarygrep がバージョンアップ

あおきにっきより

しまった。erb がない場合を考えてなかった。erb/erbl にフォールバックしてても、
erbl 自体がパスに入ってなければ意味がない。

だそうで昨日言ってた部分が直って、うちの環境でも動くかもと思ったけどやっぱり駄目みたい。

ちょっとソースを見てみた。

ERBをインクルードする部分で、

begin
  require 'erb'
  ErbEvaluator = ERB
rescue LoadError
  require 'erb/erbl'
  ErbEvaluator = ErbLight
end

もしERBが存在しなければERbLight(従来の名前)をインクルードしてるわけだけど、

ErbEvaluator = ErbLight

はERbLightでは?帰ったら試してみよう。

追記: 書き換えたら使えるようになった。


この記事へのコメント

※ このコメントは旧ブログシステム(tDiary)からの移行です。

HAJIMEさんからのコメント(2004-01-02 14:27:40)

NIKE AIR MOC ARCHS 8100

HAJIMEさんからのコメント(2004-01-02 14:31:09)

AIR MOC III

ichieさんからのコメント(2004-01-03 06:41:22)

やっと食中毒もなおりました。あと、トッツアンメビウスに赤帽9も無事入りました。あ〜もう7時だ!会社逝かなきゃ!

名前:宮内 はじめ

Code for Nagoya名誉代表

E2D3名古屋支部長

プログラマーです。GISやデータビズが好きです。このサイトは宮内の個人的なメモです。

プロフィール

お問い合わせ