そろそろRORでもやっとくか

投稿日: 2008年03月13月

というわけでRuby On Railsをやってみることにした。

rubyはaptで導入済み(Ruby 1.8.2)なので、まずはRubyGemsを導入。

$ wget http://rubyforge.org/frs/download.php/29548/rubygems-1.0.1.tgz
$ tar xvfz rubygems-1.0.1.tgz
$ cd rubygems-1.0.1
$ sudo ruby setup.rb

そしたらrdocが無いと怒られた。

./lib/rubygems/custom_require.rb:27:in `gem_original_require': no such file to load 
-- rdoc/rdoc (LoadError)
from ./lib/rubygems/custom_require.rb:27:in `require'
from setup.rb:39

しょうがないのでrdocをパッケージで導入する。

$ apt-cache search rdoc
...
rdoc - Generate documentation from ruby source files
...
$ sudo apt-get install rdoc

そうすると今度はe2fsprogsが云々言われてアップデートできない。「今RORやりたいだけで、ext2のユーティリティなんかどうでもいいんだよ(゜Д゜)ゴルァ!!」と叫びたい気持ちを抑えてググったところ、下記コマンドを実行している例があった。(注意。危険なのでお勧めしません。)

$ sudo apt-get install --reinstall e2fsprogs -o APT::Force-LoopBreak=true

が、これを実行したら依存パッケージがいくつか壊れてしまい、以降aptコマンドが使えなくなった。

名前:宮内 はじめ

Code for Nagoya名誉代表

E2D3名古屋支部長

プログラマーです。GISやデータビズが好きです。このサイトは宮内の個人的なメモです。

プロフィール

お問い合わせ